Issue Identified Monday 11th May 2020 08:17:07


We have identified an issue affecting a number of clients causing them to be unable to login to TM3 and Caseflow services.

Our infrastructure team are currently investigating. Further updates to follow shortly.

Issue resolved, we will continue to monitor the situation but expect no further services interruption for clients.

Apologies for any inconvenience caused.

We have applied a fix and are seeing services return to normal for Caseflow clients.

We continue to work on TM3 services, updates to follow shortly.